V-Ray Scene

This page provides information on the V-Ray Scene in Cinema 4D.

Overview

V-Ray Scene allows for assets to be imported from all platforms that run V-
Ray, as well as any CAD application with Enscape installed. It loads a
previously saved .vrscene file into V-Ray for Cinema 4D and supports
rendering geometry, lights, cameras, volumetrics, and materials. In addition,
it allows you to load scene overrides from a .vrscene file. There are two ways
to import a V-Ray Scene file - as a proxy or by importing all its assets as
native components. Each Import Type has different benefits and can be used
in different scenarios. For more information on Import Types, see the Import
Types section.

Keep in mind that scenes imported using V-Ray Scene are still foreign, and
not all imports can be perfect - things could look different in their original
environment and inside V-Ray for Cinema 4D.

Import Types

Native Objects (WIP)"

You can import a V-Ray Scene as Native Objects (WIP) only if you
import through the VRayScenelmport window. See the Different
ways to import for more.

This option is a work in progress - not all elements can be fully
imported. Expect improved support in the future.

This Import Type imports the scene elements separately. This
allows each element to be edited individually after import. This is
ideal if you are finishing a scene that was started on a different
machine or was created on a different V-Ray-supported platform.
You can edit individual lights, geometry, materials, and more to
complete the scene without needing to re-create everything from
scratch.

Large scenes will take some time to load, as V-Ray Scene is reading
all the individual elements and importing them separately.

If you are importing a V-Ray scene with Gamma corrections as
Native Objects (WIP) from V-Ray for 3ds Max, please see this section
for an import guide.
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Black Box Objects

Black box objects are imported completely, but they are closed for
editing - the user cannot tweak their contents. Black Box Objects are

displayed with the icon. For a list of the unsupported
components, see the Limitations section.
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V-Ray Scene Reference

The V-Ray Scene Reference Import Type imports the V-Ray Scene file as a
proxy - its components cannot be individually edited, but the proxy can be
edited as a whole. This Import Type is more compact and saves processing
power. If no further edits need to be made to the scene, we recommend
using this method for transferring V-Ray scenes.

You can convert a Scene Reference into a Native Objects (WIP) after
importing.




Parameters
File Path — Allows you to browse for and specify the .vrscene file.

Flip Axis Mode — Controls which axis is used as a vertical - the Y or Z axes
for the loaded vrscene. You can choose between:

As Is — No changes in the axes are applied.

Auto — It aligns the vertical axis of the vrscene with the vertical axis in
the current scene in cases where the vrscene was not exported from
3ds Max. Use the Auto mode when loading a USD file.

Z-Up to Y-Up — Switches the Z and Y axes.

Y-Up to Z-Up — Switches the Y and Z axes.

Include Geometry — When enabled, renders all the geometry in the .vrscene
file.

Include Lights — When enabled, renders all the lights in the .vrscene file.

Material Override — Override all the V-Ray scene materials with the V-Ray
material selected in this field.

Z-Up to Y-Up

Animation Overrides
Enable Animation Override — Enables Animation overrides.

Speed — Speed multiplier for the animation. A value of 1 plays the animation
at normal speed.

Playback Type — Specifies how to read the animation in the .vrscene.

Loop — Plays the entire animation, then restarts on the initial frame.
Play once — Plays the animation once, then displays the last frame of
the animation for all further frames.

Ping-pong — When the end of the animation is reached, the
animation is reversed.

Still — Displays only one frame.

Offset — Shifts the start frame.

Start — Determines which frame is considered the first frame of the
animation.

Length — Sets the length of the animation. If this value is less than the total
number of frames, the animation is clipped. If it is greater than the number of
frames, the Playback Type option determines how the extra frames are
interpreted.

Animation Override

<& Enable Animation Override

VRayScenelmport



The VRayScenelmport window prompts you to select some import options
for the .vrscene file. The Presets tab is a Cinema 4D tab that allows you to
save and reuse settings as presets.

Import Type — Determines how the file is read when imported. See the Impor
t Types section for more information.

Native Objects ONIP)* — The elements in the file are read and
imported individually as separate native objects as if the scene was
created locally. This allows for greater editability of the imported V-
Ray scene. Keep in mind that not all assets will be imported
properly due to their nature - elements that are not supported by V-
Ray for Cinema 4D and elements that are not supported by V-Ray
Scene, currently cannot be imported natively.

V-Ray Scene Reference — The file is imported as a V-Ray Scene
geometry. Edits to the scene are limited to the V-Ray Scene parame
ters.

GENERAL

Flip Axis Mode — Controls which axis is used as a vertical - the Y or Z axes
for the loaded vrscene. You can choose between:

As Is — No changes in the axes are applied.

Auto — It aligns the vertical axis of the vrscene with the vertical axis in
the scene in cases where the vrscene was not exported from 3ds Max.
Use the Auto mode when loading a USD file.

Z-Up to Y-Up — Switches the Z and Y axes.

Y-Up to Z-Up — Switches the Y and Z axes.

IMPORT TYPES

Geometry — Allows the import of all the geometry from the .vrscene file.

Lights — Allows the import of all the lights from the .vrscene file

Instances (WIP) “ — Allows the import of Instance Objects that were
exported using Render Instance mode.

Materials — Allows the import of all the materials from the .vrscene file.
Scenes exported from Maya will have their place2dTexture replaced with the
V-Ray for Cinema 4D equivalent, which is the UVW Place 2D node and
classic textures.

Cameras — Allows cameras to be imported from the .vrscene file.
Optimize Shaders - Optimizes the shaders and textures without altering
their look. We recommend keeping this option on.

PREVIEW

Preview — Specifies one of the following modes for previewing the selected .
vrscene in the viewport:

Preview Geometry — Displays a preview of the .vrscene using the
value of the Face Count parameter.

Bounding Box — Displays a preview of the .vrscene using bounding
boxes.

Points — Displays the .vrscene using points.

Disabled — Hides the .vrscene.

Face Count — Determines the number of faces that are used for previewing
the .vrscene file.
ANIMATION OVERRIDE

Enable Animation Override — Enables the following parameters found in
the Animation Overrides rollout.

Speed — Determines the pace at which the animation plays. The default of 1
plays at the speed for which the animation was created.

Playback Type — Specifies how to read the animation in the .vrscene.


#

Loop — Plays the entire animation, then restarts on the initial frame.
Once — Plays the animation once, then displays the last frame of the
animation for all further frames.

Ping-pong — When the end of the animation is reached, the
animation is reversed.

Still — Displays only one frame.

Offset — Shifts the start frame.

Start — Determines which frame is considered the first frame of the
animation.

Length — Sets the length of the animation. If this value is less than the total
number of frames, the animation is clipped. If it is greater than the number of
frames, the Playback Type option determines how the extra frames are
interpreted.
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Transfer Enscape Scenes Using V-Ray Scene files

Import geometry, shading, lights, and cameras in a Cinema 4D
scene from a .vrscene file exported by Enscape.

Use .vrscene files exported with Enscape version 3.5.6 or newer.

Files exported with earlier Enscape versions may not contain proper
descriptions of the imported data. See the video for an example.

How to Import a V-Ray Scene

Drag-n-drop
To import a vrscene file, you can use the drag-and-drop functionality.
The VRayScenelmport window prompts you to choose how to import

the file in Cinema 4D. See the VRayScenelmport section of this page
for descriptions of all the options.
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File > Open Project

Go to File > Open Project and select a .vrscene file. The VRayScen
elmport window prompts you to choose how to import the V-Ray
Scene into Cinema 4D.

You can also merge a V-Ray Scene into your current scene by
loading it from the File > Merge Project option.
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V-Ray Toolbar

Go to the V-Ray menu > Tools > V-Ray Toolbar. The V-Ray Toolbar
is a palette that can be docked anywhere in the interface.

Select V-Ray Scene (| ) and select a .vrscene file. The file is
imported as a V-Ray Scene Reference.
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https://docs.chaos.com/display/VC4D/V-Ray+Toolbar

Through V-Ray menu

You can import a .vrscene file using the V-Ray menu. Select Geomet
ry > V-Ray Scene.

From Attributes, go to the General tab of the V-Ray Scene. From File

Path, select the .vrscene file. It loads in the 0,0,0 coordinates in
Cinema 4D. The file is imported as a V-Ray Scene Reference.
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VRmat material import

If you only want to import the materials from a .vrscene file, you can
use the VRmat material or material node to do so. Create a VRmat
material or material node and attach your .vrscene file in the Material
File field. You can then select a specific material from the file using
the Material Name dropdown menu.

Attributes

Mode Edit User Data

Importing Native Objects (WIP) from V-Ray for 3ds Max with Gamma Corrections

The TexMaxGamma node is imported from older V-Ray for 3ds Max scenes
only when the Optimize Shaders option is enabled during import in the
VRayScenelmport window.


https://docs.chaos.com/display/VC4D/VRmat+Material
https://docs.chaos.com/display/VC4D/VRmat+Node+Material

If you are importing a .vrscene file as a Native Object from an older V-Ray
for 3ds Max scene, the materials in that file will import into V-Ray for Cinema
4D only as classic materials with a VRayMaxGamma shader attached. This
texture helps properly transfer the color settings. However, the
VRayMaxGamma node can prevent the imported materials from being
converted to V-Ray Node materials through the Convert Materials tool.

The exception is if the materials are exported with a Gamma of 1. In that
case, they are imported into V-Ray for Cinema 4D seamlessly without the
creation of a VRayMaxGamma texture.

If that is not the case and a different Gamma value is assigned to the
materials, you need to adjust the settings of the VRayMaxGamma textures of
each material. Keep in mind that these alterations might change the look of
your imported shaders. You can either set the Color Space of the
VRayMaxGamma to Linear and set the Multiplier value to 1 or set the Color
Space to Inverse Gamma and set both the Multiplier and Gamma values to
1. These settings allow V-Ray to skip the VRayMaxGamma texture when
converting, allowing the rest of the material to be converted into a Node
material.
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This image is only for illustrative purposes; it does not correspond to
the default interface.

Convert a Scene Reference to a Native Object (WIP)

To convert a V-Ray Scene Reference into a Native Object, select the V-Ray

)

Vg
Scene Reference and click on the Make Editable button. You can
then edit all of its components if they are supported”.
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How to Export a V-Ray Scene

To export a .vrscene file from Cinema 4D, go to File > Export... and select
the V-Ray Scene option.

File Edit

V-Ray Scene (*.vrscene)

Settings
Presets

The Presets option allows you to save any configuration for future use.

Scene Export

Separate files — When enabled, V-Ray exports separate files for different
components of the scene. This also allows you to disable export for certain
types of objects: Lights, Nodes, Geometry, Materials, Textures, and Bitma

ps.

Each frame in separate file — When enabled, V-Ray makes a separate file
for each rendered frame.

Strip paths — When enabled, the paths for assets (bitmap textures, proxies,
Gl caches loaded from file, etc.) are removed from the exported file and only
the file names of the assets remain.



Write mesh data in hex format — When enabled (the default), the mesh
data is written in hexadecimal format in the .vrscene file. This makes the files
smaller and faster for processing, but less readable to a user. When
disabled, the mesh data is written in normal decimal format.

Write transform data in hex format — When enabled (the default),
transform data is written in hexadecimal format in the .vrscene file. This
makes the files smaller and faster for processing, but less readable to a user.
When disabled, the data is written in normal decimal format.

Compressed — When enabled, basic compression is applied to the .vrscene
file. This option can only be used together with Write mesh data in hex
format.

Skip exporting plugins

When exporting an animation, these options select which plugin to be
included.

Skip Exporting Objects and Lights:

Export All — Exports only render settings and objects, and lights.
Skip All — Skips the export of Objects and Lights.

Export First Frame Only — Exports the render settings and
objects, and lights to the first frame of the animation.

Skip Exporting Materials

Export All — Exports only render settings and materials.
Skip All — Skips the export of Materials.

Export First Frame Only — Exports the render settings and
materials to the first frame of the animation.

Skip Exporting Cameras

Export All — Exports only render settings and cameras.
Skip All — Skips the export of Cameras.

Export First Frame Only — Exports the render settings and
cameras to the first frame of the animation.

Skip Exporting Render Elements

Export All — Exports only render settings and render elements.
Skip All — Skips the export of Render Elements.

Export First Frame Only — Exports the render settings and render
elements to the first frame of the animation.

Presets Scene Export

Presets

Presets Default « Save...

Scene Export

> Separate
Each frar
Strip paths
Write mesh data in hex fi
Write transform data in he
Compressed
v SKIP EXPORTING PLUGINS
Skip Exporting Objects and Lights Export All
Skip Exporting Materials Export All
Export All
Export All

OK Cancel




Limitations

© V-Ray Sky is currently not supported for import with V-Ray Scene.
Native Objects mode:

© V-Ray elements that are applied only to their child components, e.g., V-Ray Clipper, V-Ray Particles, and V-Ray Renderable Spline and hairs, are
imported as black box objects.

Materials that cannot be created natively in V-Ray for Cinema 4D are currently not supported in V-Ray Scene.

If different materials are assigned to instances, they will currently not render exactly the same as in the original scene.
Instances of proxy files are not currently imported correctly in V-Ray Scene.

Render Settings are currently not importable.

Animation and animated geometry are currently not supported.

V-Ray Mesh Light imports as a black box object.

V-Ray Volume Grid imports as a black box object.

Animated instances are currently not supported.

Light and Shadow Linking is currently not supported.

Custom User Data is currently not supported.
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